博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
zju 1006 zoj 1006
阅读量:4120 次
发布时间:2019-05-25

本文共 3668 字,大约阅读时间需要 12 分钟。

Do the Untwist

Time Limit: 2 Seconds     
Memory Limit: 65536 KB

Cryptography deals with methods of secret communication thattransform a message (the plaintext) into a disguised form (theciphertext) so that no one seeing the ciphertext will be ableto figure out the plaintext except the intended recipient.Transforming the plaintext to the ciphertext is encryption;transforming the ciphertext to the plaintext is decryption.Twisting is a simple encryption method that requires that thesender and recipient both agree on a secret key k, which is apositive integer.

The twisting method uses four arrays: plaintext and ciphertextare arrays of characters, and plaincode and ciphercode arearrays of integers. All arrays are of length n, where n is thelength of the message to be encrypted. Arrays are origin zero, so theelements are numbered from 0 to n - 1. For this problem allmessages will contain only lowercase letters, the period, and theunderscore (representing a space).

The message to be encrypted is stored in plaintext. Given a keyk, the encryption method works as follows. First convert theletters in plaintext to integer codes in plaincode according tothe following rule: '_' = 0, 'a' = 1, 'b' = 2, ..., 'z' = 26,and '.' = 27. Next, convert each code in plaincode to anencrypted code in ciphercode according to the following formula: for alli from 0 to n - 1,

ciphercode[
i] = (
plaincode[
ki mod
n]
-
i) mod 28.

(Here x mod y is the positive remainder when x is divided by y.For example, 3 mod 7 = 3, 22 mod 8 = 6, and -1 mod 28 = 27. Youcan use the C '%' operator or Pascal 'mod' operator to computethis as long as you add y if the result is negative.)Finally, convert the codes in ciphercode back to letters inciphertext according to the rule listed above. The final twistedmessage is in ciphertext. Twisting the message cat using the key 5yields the following:

Array 0 1 2
plaintext 'c' 'a' 't'
plaincode 3 1 20
ciphercode 3 19 27
ciphertext 'c' 's' '.'

Your task is to write a program that can untwist messages,i.e., convert the ciphertext back to the originalplaintext given the key k. For example, given the key 5 andciphertext 'cs.', your program must output the plaintext 'cat'.

The input file contains one or more test cases, followed by a linecontaining only the number 0 that signals the end of the file.Each test case is on a line by itself and consists of the key k, aspace, and then a twisted message containing at least one and at most 70characters. The key k will be a positive integer not greater than300. For each test case, output the untwisted message on a lineby itself.

Note: you can assume that untwisting a message always yieldsa unique result. (For those of you with some knowledge of basic numbertheory or abstract algebra, this will be the case provided that thegreatest common divisor of the key k and length n is 1, which it will be for all test cases.)

Example input:

5 cs.101 thqqxw.lui.qswer3 b_ylxmhzjsys.virpbkr0

Example output:

catthis_is_a_secretbeware._dogs_barking

这题主要的问题在于如何求plaincode,由题中的公式可得plaincode[ki mod n] =(ciphercode[i]+i) mod 28,通过循环把每一个求出来即可

#include<iostream>

#include<string>
using namespace std;
char plaincode[28];
int plain[1000];
int main(){
    string ciphertext,plaintext;
    int key,n,ciphercode[1000];
    plaincode[0]='_';
    plaincode[27]='.';
    for(int i=1;i<27;i++){
        plaincode[i]=i+'a'-1;
    }
    while(cin>>key,key){
        cin>>ciphertext;
        n=ciphertext.size();
        for(int i=0;i<n;i++){
            for(int j=0;j<28;j++){
                if(plaincode[j]==ciphertext[i]) ciphercode[i]=j;
            }
        }
        plaintext="";
        for(int i=0;i<n;i++){
            plain[key*i%n]=(ciphercode[i]+i)%28;
        }
        for(int i=0;i<n;i++){
            plaintext+=plaincode[plain[i]];
        }
        cout<<plaintext<<endl;
    }
    return 0;
}

转载地址:http://qxtpi.baihongyu.com/

你可能感兴趣的文章
服务器端技术----Http请求的处理过程
查看>>
C语言-预处理指令2-条件编译
查看>>
C语言-预处理指令3-文件包含
查看>>
C语言-变量类型
查看>>
C语言-static和extern关键字1-对函数的作用
查看>>
C 语言-static和extern关键字2-对变量的作用
查看>>
【JavaScript 教程】浏览器—History 对象
查看>>
还不会正则表达式?看这篇!
查看>>
100道+ JavaScript 面试题,助你查漏补缺
查看>>
JavaScript深入理解之闭包
查看>>
这才是学习Vite2的正确姿势!
查看>>
7 个适用于所有前端开发人员的很棒API,你需要了解一下
查看>>
25个构建Web项目的HTML建议,你需要了解一下!
查看>>
【web素材】02-10款大气的购物商城网站模板
查看>>
6种方式实现JavaScript数组扁平化(flat)方法的总结
查看>>
如何实现a===1 && a===2 && a===3返回true?
查看>>
49个在工作中常用且容易遗忘的CSS样式清单整理
查看>>
20种在学习编程的同时也可以在线赚钱的方法
查看>>
隐藏搜索框:CSS 动画正反向序列
查看>>
12 个JavaScript 特性技巧你可能从未使用过
查看>>